Only iPhones that can’t run iOS 16 are getting new iOS 15 updates

Enlarge / iPhones running iOS 15. (credit: Apple)

As part of the barrage of operating system updates released earlier today, Apple published new iOS and iPadOS 15.7.2 updates that bring most of the iOS 16.2 security patches to the previous version of the operating system.

Both 15.7 and 15.7.1 were released after iOS 16 became available, and they served two purposes: to support newer devices whose owners didn’t want to jump to iOS 16 and older devices that weren’t able to run iOS 16. The iOS 15.7.2 update supports a smaller number of devices. From Apple’s security updates page, emphasis ours:

Available for: iPhone 6s (all models), iPhone 7 (all models), iPhone SE (1st generation), iPad Pro (all models), iPad Air 2 and later, iPad 5th generation and later, iPad mini 4 and later, and iPod touch (7th generation)

Any iPad owner running iPadOS 15 can still download the 15.7.2 update instead of iPadOS 16, but newer iPhones will need to install iOS 16.2 to get all the latest security patches. The company did something similar last year and supported iOS 14 for a couple of months after iOS 15 came out but eventually ended iOS 14 support. (iPhones and iPads may be treated differently this year because the first version of iPadOS 16 released to the public came out a month after the first release of iOS 16.)

Read 2 remaining paragraphs | Comments